PRND readout problem - PerformanceTrucks.net Forums

GMT 800 & Older GM General Discussion 2006 & Older Trucks | General Discussion

PRND readout problem

Reply

Old 05-17-2018, 12:01 AM
  #1  
Teching In
Thread Starter
 
Join Date: Feb 2017
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default PRND readout problem

Hey guys iI'm having an issue in my 2002 silverado where it shifts through all of the gears no problem but the display lags behind or doesn't change. It changes from P to drive with no issues but once i get into 3, 2, or 1 itll still show D. sometimes after driving for a couple of second it will finally change to the correct read out. I feel like the gauge cluster is fine and it seems like a loose connection almost? any help is appreciated and thank in advance guys!

Truck is a 2002 silverado with a built 4l65e and lq4.
2004_Sierra_Lq4 is offline  
Reply With Quote
Old 05-17-2018, 01:31 PM
  #2  
Still moddin'
iTrader: (7)
 
Reckless's Avatar
 
Join Date: Nov 2001
Location: Vengeance Racing
Posts: 9,880
Thanks: 0
Thanked 1 Time in 1 Post
Default

Prob just need a new safety switch

https://www.summitracing.com/parts/a...iABEgIYYvD_BwE
Reckless is offline  
Reply With Quote
Reply
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
vandal699
Tuning, Diagnostics, Electronics, and Wiring
2
02-24-2013 12:06 PM
1936 LS1
GM Parts Classifieds
0
08-01-2011 04:20 PM
jschwartze
GMT 800 & Older GM General Discussion
2
11-18-2007 07:05 AM
glock35ipsc
GM Engine & Exhaust Performance
5
05-10-2005 03:02 PM
wkdivr
GM Engine & Exhaust Performance
4
07-08-2004 11:45 AM


Thread Tools
Search this Thread
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: