p2761 - PerformanceTrucks.net Forums



p2761

Reply
 
Thread Tools Search this Thread
Old 10-09-2010, 09:34 AM   #1
TECH Resident
Thread Starter
iTrader: (20)
 
SmokinHot98's Avatar
 
Join Date: Jun 2005
Location: Lansing,IL
Posts: 890
Thanks: 0
Thanked 0 Times in 0 Posts
Default p2761

what could cause to to get thrown, why TC seems VERY loose to for what its worth.

Threw the code on the way to a wedding, and then the trans was getting pretty hot
SmokinHot98 is offline   Reply With Quote
Old 10-09-2010, 09:54 AM   #2
PT's Slowest Truck
iTrader: (19)
 
budhayes3's Avatar
 
Join Date: Apr 2004
Location: Hackensack, NJ
Posts: 17,869
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't have all of the P codes memorized yet lol, what is a P2761?
budhayes3 is offline   Reply With Quote
Old 10-09-2010, 11:46 AM   #3
TECH Resident
Thread Starter
iTrader: (20)
 
SmokinHot98's Avatar
 
Join Date: Jun 2005
Location: Lansing,IL
Posts: 890
Thanks: 0
Thanked 0 Times in 0 Posts
Default

from what i've found

P2761 = Torque Converter Clutch Pressure Control Solenoid Control Circuit/Open
SmokinHot98 is offline   Reply With Quote
Old 10-09-2010, 04:58 PM   #4
TECH Enthusiast
 
Mrgoodwrench3's Avatar
 
Join Date: Jan 2010
Location: Huntington Beach, CA
Posts: 510
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does it feel like the transmission is stuck in 3rd gear? The ignition switch is a common failure for this code.
Mrgoodwrench3 is offline   Reply With Quote
Old 10-10-2010, 10:26 AM   #5
TECH Resident
Thread Starter
iTrader: (20)
 
SmokinHot98's Avatar
 
Join Date: Jun 2005
Location: Lansing,IL
Posts: 890
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yea, and its sucking the crap outta my gas.... then again its a modded 6.0, lol.

It bugs me that the RPM's sit so high. 65 sits @2300 cruising and tap the gas it jumps to 2700-2800.

The TC seems to be bouncing out of lock-up to. So how would I go about fixing this?

thanks
SmokinHot98 is offline   Reply With Quote
Old 10-10-2010, 10:42 AM   #6
PT's Slowest Truck
iTrader: (19)
 
budhayes3's Avatar
 
Join Date: Apr 2004
Location: Hackensack, NJ
Posts: 17,869
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by SmokinHot98 View Post
yea, and its sucking the crap outta my gas.... then again its a modded 6.0, lol.

It bugs me that the RPM's sit so high. 65 sits @2300 cruising and tap the gas it jumps to 2700-2800.

The TC seems to be bouncing out of lock-up to. So how would I go about fixing this?

thanks
If the problem is what MrGoodwrench3 mentioned, then replacing the ignition switch will solve your issue
budhayes3 is offline   Reply With Quote
Old 10-10-2010, 11:18 AM   #7
TECH Resident
Thread Starter
iTrader: (20)
 
SmokinHot98's Avatar
 
Join Date: Jun 2005
Location: Lansing,IL
Posts: 890
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, I'll try that. Thanks guys, its been one thing after another bt I think this is the last issue.

I put in my tru-cool 40k cooler yesterday and dropped the temps 60-80*, boy was I happy
SmokinHot98 is offline   Reply With Quote
Old 10-10-2010, 12:54 PM   #8
PT's Slowest Truck
iTrader: (19)
 
budhayes3's Avatar
 
Join Date: Apr 2004
Location: Hackensack, NJ
Posts: 17,869
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by SmokinHot98 View Post
ok, I'll try that. Thanks guys, its been one thing after another bt I think this is the last issue.

I put in my tru-cool 40k cooler yesterday and dropped the temps 60-80*, boy was I happy
Very nice, hopefully that will help extend the life of your trans so you have one less thing to worry about
budhayes3 is offline   Reply With Quote
Old 11-01-2010, 05:57 PM   #9
On The Tree
iTrader: (1)
 
Join Date: Jul 2008
Location: Mass
Posts: 173
Thanks: 0
Thanked 0 Times in 0 Posts
Default

any update?
Cook is offline   Reply With Quote
Old 02-21-2011, 01:09 AM   #10
TECH Resident
Thread Starter
iTrader: (20)
 
SmokinHot98's Avatar
 
Join Date: Jun 2005
Location: Lansing,IL
Posts: 890
Thanks: 0
Thanked 0 Times in 0 Posts
Default

sorry its been awhile since I've been on here, but not really. The Ignition switch actually crapped out on me totally so i replaced it and the code has stayed there. When it gets warmer out I have to run over all the grounds to make sure they have a good connection, because I have a huge draw in power when running many accessories. Or it could be the battery.... not sure
SmokinHot98 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
4l60e problems. I give up... bossmancb GM Drivetrain & Suspension 27 06-22-2015 11:05 PM
any ideas? darnie Tuning, Diagnostics, Electronics, and Wiring 0 06-06-2014 09:10 AM
transmission codes chadillac06 GMT 800 & Older GM General Discussion 1 11-08-2013 12:02 AM
Help Yet Again Please wifesta GM Drivetrain & Suspension 0 07-23-2008 06:14 AM


Tags
2005, chevy, circuitopen, clutch, code, control, converter, general, gm, motors, p2761, p2761torque, pressure, silverado, solenoid, troubleshoot

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:19 PM.